Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заранее

elbrusikus elbrusikus    3   28.09.2019 09:02    3

Ответы
yarabar yarabar  11.08.2020 08:26

#include <stdio.h>

#include <stdlib.h>


int main()

{

int number;

scanf("%d", &number);

number = abs(number);

if(number % 2 != 0)

{

 printf("Не является!");

 return 0;

}

while(number > 2)

{

 number /= 2;

}

if(number == 2)

 printf("Является!");

else printf("Не является!");

}


Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.заране
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика