Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу которая суммирует эти два массива и объединяет в один

ВІДМІННИК11 ВІДМІННИК11    2   21.09.2019 15:40    4

Ответы
Алекс2241 Алекс2241  08.10.2020 07:26
//Я так понял, что нужно объеденить 2 массива в 1 большой. Если же нужно, чтобы каждый элемент третьего массива состоял из суммы элементов с такии же индексом двух предыдущих массивов, то нужен другой код

Program Test;

const Size = 5; x = 1; y = 10;

Var i, j, Entered: integer; Arr1: array[1..Size] of integer; Arr2: array[1..Size] of integer; Arr3: array[1..Size * 2] of integer;

Begin

Randomize;

j := 0;

for i := 1 to Size do
begin
Arr1[i] := Random(x, y);
Arr2[i] := Random(x, y);
end;

for i := 1 to Size * 2 do
begin
if (i <= Size) then
Arr3[i] := Arr1[i]

else
begin
j := j + 1;
Arr3[i] := Arr2[j];
end;
end;

Write('Показать 1 массив? Если да, то введи 1: ');
Readln(Entered);

if (Entered = 1) then
begin
Writeln();

for i := 1 to Size do
Writeln('Элемент ', i, ' = ', Arr1[i]);
end;

Writeln();
Entered := 0;

Write('Показать 2 массив? Если да, то введи 2: ');
Readln(Entered);

if (Entered = 2) then
begin
Writeln();

for i := 1 to Size do
Writeln('Элемент ', i, ' = ', Arr2[i]);
end;

Writeln();
Writeln('Суммарный массив:');
Writeln();

for i := 1 to Size * 2 do
Writeln('Элемент ', i, ' = ', Arr3[i]);

End.
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика