Нужно решить на языке паскаль. изучаем string. 1.дана строка. написать программу, выводящую сумму порядковых номеров заданного символа. 2.дано предложение состоящее из заглавных букв. в предложении только одно слово в котором 3 буквы. вам нужно написать программу которая найдет это слово и выведет его в файл.

НеШкольник228228 НеШкольник228228    3   21.08.2019 14:50    2

Ответы
NameXD NameXD  26.08.2020 07:55
//PascalABC.NET 3.2 сборка 1318

Var
  s:string;
  c:char;
  sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.

Пример ввода:
konichiva
i
Пример вывода:
11

//2
Var
  f:text;
  s:string;
  i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length<>3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
  
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика