Нужно написать программу в паскале возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число r.

vladacherry2003 vladacherry2003    1   04.10.2019 13:40    2

Ответы
mila2086 mila2086  27.08.2020 12:47

var

 r, i: integer;

 

begin

 readln(r);

 for i := 0 to r do write(power(i, 2), ' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
zlatochkagr zlatochkagr  27.08.2020 12:47

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];

write (a[i]:3,' ')

end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика