Нужно написать программу в паскале описать функцию quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). с этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

mnl39 mnl39    3   07.06.2019 10:20    7

Ответы
Gklunnyy123 Gklunnyy123  07.07.2020 07:39
Var
   i: integer;
   x,y:real;

function Quarter(x,y:real):integer;
begin
if (x>0) and (y>0) then result:=1;
if (x<0) and (y>0) then result:=2;
if (x<0) and (y<0) then result:=3;
if (x>0) and (y<0) then result:=4;
end;

begin
writeln('Введите координаты точки');
readln(x,y);
i:=Quarter(x,y);
writeln('Номер координатной четверти; ',i)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика