Нужно написать программу в паскале найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

ladomix ladomix    3   15.06.2019 06:30    2

Ответы
DASHA56789111 DASHA56789111  12.07.2020 13:53
Var i, a, b, t, d, n : integer;
x : array of integer;
begin
    read(n);
    SetLength(x, n + 1);
    for i := 1 to n do
        read(x[i]);
    a := x[1];
    for i := 2 to n do begin
        b := x[i];
        d := a * b;
        while (b > 0) do begin
            t := a;
            a := b;
            b := t mod b;
        end;
        a := d div a;
    end;
    writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика