Нужно написать программу в паскале. 1. найти площадь закрашенной фигуры если известны стороны прямоугольника и радиус круга 2. найти гипотенуза прямоугольного треугольника если известно его площадь и один из катетов. числа можете подставить любые

esbolat2000 esbolat2000    1   24.09.2019 06:40    3

Ответы
voegrogo5523 voegrogo5523  08.10.2020 14:19
1. Ну я не знаю какая часть фигуры закрашена. Будем считать что прямоугольник находиться в окружности и необходимо из площади курга вычесть площадь прямоугольника.
const
p =3.14;
var
a,b,r,s1,s2:real;
begin
Writeln('Введите длины сторон прямоугольника');
readln(a,b);
Writeln('Введите радиус окуржности');
Readln(r);
s1:=a*b;
s2:=p*sqr(r);
Writeln('Площадь закрашеной окружности = ', s2-s1);
end.

Если закрашена какая-то другая область то можете просто изменить действие с площадями в предпоследней строчке ( в данном случае мы из s2 вычитаем s1).
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика