Нужно написать программу в Pascal: пользователь вводит число в десятичной системе, а программа должна перевести это число в двуичный код. Желательно сделать 1 программу простой, с использованием if, div, mod, ну и циклы если надо,кроме цикла repeat, например пользователь ввёл 5 а система перевела в двуичный код 101

МитинЗахар МитинЗахар    1   02.08.2020 12:27    3

Ответы
annaegorova4 annaegorova4  15.09.2020 06:47

program ToBinary;

procedure dec2bin(var s : string; num : integer);

begin

   if num > 0 then begin

       dec2bin(s, num div 2);

       if num mod 2 = 0 then

           s := s + '0'

       else

           s := s + '1';

   end;

end;

var

 a : integer;

 s : string;

begin

 read(a);

 dec2bin(s, a);

 writeln(s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика