Нужно написать программу шахматная доска состоит из n х m клеток, покрашенных в черный и белый цвет в«шахматном» порядке. при этом клетка в левом нижнем углу доски покрашена в черный цвет определите, сколько всего на доске черных клето. программа получает на вход два числа n и m, залисанных в отдельных строю bсе натуральные, не превосходящие 30 000 числа программа должна вывести одно целое число количество черных клеток на доске.

DashaL04 DashaL04    3   12.06.2019 05:40    34

Ответы
JlU40K JlU40K  09.07.2020 21:01
Рассмотрим случай, когда число клеток по вертикали n четное. В этом случае каждая пара горизонталей доски содержит ровно m клеток (m - число клеток доски по горизонтали). Тогда общее число черных клеток равно m*n/2.
При нечетном n к рассмотренным горизонтальным строкам добавляется еще одна - нечетная, конфигурация которой совпадает с первой (нечетной) горизонталью.
Если клетка в левом нижнем углу первой горизонтали черная, то количество черных клеток в ней можно определить как сумму результата целочисленного деления количества клеток по горизонтали на два и остатка от этого деления. В результате приходим к следующей формуле:
k=\begin {cases} \frac{mn}{2}, \ n \, mod \, 2=0 \\ \frac{m(n-1)}{2}+ (m \, div \, 2)+(m \, mod \, 2), \ n \, mod \, 2=1 \end {cases}

Ниже представлен текст программы на языке Pascal.ABC.NET

var
  m, n: integer;

begin
  Write('Введите количество горизонталей на доске: ');
  Readln(n);
  Write('Введите количество вертикалей на доске: ');
  Readln(m);
  if (n mod 2) = 0 then Writeln('Черных клеток на доске- ', m * n / 2)
  else Writeln('Черных клеток на доске- ', m * (n-1) / 2 + (m div 2) + (m mod 2))
end.

Тестовое решение:

Введите количество горизонталей на доске: 8
Введите количество вертикалей на доске: 7
Черных клеток на доске- 28
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика