Нужно написать программу подсчитывающую количество чётных и не чётных цифр в числе

Mercedess65amg Mercedess65amg    1   06.07.2019 21:20    3

Ответы
Маря04 Маря04  29.07.2020 23:22
//PascalABC.Net 3.0, сборка 1053
var
  n: longint;
  d, n1, n2: integer;

begin
  n1 := 0; n2 := 0;
  Write('Введите натуральное число: ');Read(n);
  repeat
    d := n mod 10;
    if odd(d) then Inc(n1) else Inc(n2);
    n := n div 10
  until n = 0;
  Write('Нечетных ', n1, ', четных ', n2)
end.

Тестовое решение:
Введите натуральное число: 3534052
Нечетных 4, четных 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика