Нужно написать программу паскаль.. 7.62. даны натуральное число n и целые числа a1, a2, a3, …a9. найти: а) номер максимального из чисел ai,. если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

nekodaf nekodaf    1   15.03.2019 13:30    3

Ответы
Bearina Bearina  25.05.2020 12:55

program asd;
uses crt;
var
i:integer;
a: array[1..9] of integer;
naibnum:integer;
naib:integer;
naim:integer;
naimnum:integer;
begin
writeln('Вводите цифры');
for i:=1 to 9 do
begin
readln(a[i]);

if i = 1 then naim:=a[i];
if i = 1 then naib:=a[i];
if a[i] < naim then
begin
naim:=a[i];
naimnum:=i;
end;

if a[i] > naib then
begin
naib:=a[i];
naibnum:=i;
end;
end;

writeln('Наименьшее:',naim, ' номер:', naimnum);
writeln('Наибольшее:',naib, ' номер:', naibnum);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика