Нужно написать программу. найдите сумму цифр не кратных 3 и произведение цифр больших 5 в записи числа.

Morkovka911 Morkovka911    1   30.06.2019 11:10    2

Ответы
ArtemkaRus71 ArtemkaRus71  24.07.2020 01:46
 var   
a,b,s,p : integer;    
begin 
readln (a); 
s := 0; 
p := 1;   

while a > 0 do   
begin   
b := a mod 10;   
a := a div 10;       
if b mod 3 <> 0 then     
s := s + b;   
if b > 5 then     
p := p * b;   
end;    
if p = 1 then   
p := 0;       
writeln (s);   
writeln (p); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика