Нужно написать программу на языке паскаль. С клавиатуры вводятся длины сторон К
прямоугольников. Посчитать количество вертикально
расположенных и количество горизонтально
расположенных прямоугольников, исходя из того, что
сторона А всегда параллельна оси Х, а сторона В -
оси У.

Dasha2302 Dasha2302    2   05.10.2021 09:29    6

Ответы
madishalabaev madishalabaev  29.11.2021 04:46

var

 a,b,k,i,k1:integer;

begin

 write('Сколько фигур: '); readln(k);

 b:=0; k1:=0;

 for i:=1 to k do

   begin

     write('Стороны ',i,'-го треугольника(A B): '); readln(a,k);

     if a>=k then  

       if a>k then  

         inc(b)

           else inc(k1);

   end;

 writeln('Горизонтальных: ',b);

 writeln('Вертикальных: ',i-b-k1);

 if k1<>0 then

 writeln('Квадратов: ',k1);

end.

Если моё решение вам, пометьте его лучшим !

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика