Нужно написать программу на языке паскаль, которая будет убирать из строки все символы кроме цифр. пример: входной- a3f4h5k& 2 выходной: 3452

dasha5132 dasha5132    2   19.07.2019 13:40    1

Ответы
Bdof72005 Bdof72005  15.09.2020 19:17
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString;
  s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
  Writeln(s)
end.

Тестовое решение:
a3f4h5k&2
3452
ПОКАЗАТЬ ОТВЕТЫ
Kristina1536289 Kristina1536289  15.09.2020 19:17
Var s:string;
l,i:longint;
begin
read(s);
l:=length(s);
for i:=1 to l do
if (s[i]>='0')and(s[i]<='9') then write(s[i]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика