Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 выходит найти ошибку


Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых
Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых

MariaGraf MariaGraf    1   06.02.2021 21:02    8

Ответы
Amina1225 Amina1225  08.03.2021 21:19

#include<iostream>

#include<cmath>

using namespace std;

int main()

{

int n;

cin >> n;

int p = 1;

float sum = 0;

for (float i = 1; i <=n; i++)

{

p *= i;

sum += (pow(-1, i) * (i + 1)) / (p);

}

cout << sum;

}

//вместо n ты должна была написать i

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика