tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно написать программу
Нужно написать программу на с++ мы вводим массив из букв, а программа должна их отсортировать по алфавиту
Windows95
3 21.09.2019 01:10
3
Ответы
zheniskanovaa
08.10.2020 05:55
#include <iostream>
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы:
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
gireeva00
26.01.2021 21:12
Определите, к какому информационному процессу (хранение, передача, обработка) главным образом относится каждый из приведённых примеров: а) определение цены деления измерительного...
Anastasia2003272
27.07.2019 14:30
1. дан массив в(7). найти модуль минимального и квадратный корень максимального элементов массива. массив заполняется с клавиатуры. 2. массив d(6) задан на [-1,50)....
poliaaaaaa
27.07.2019 14:20
Раздели фигуру на 4 равные части так чтобы линия разреза проходила по сторонам клетом найди несколько...
vefremka
27.07.2019 14:20
Сумма 10 000 рублей положена в банк. прирост - 5% годовых. через сколько лет сумма увеличится вдвое? составить программу на паскаль...
alimbekoffniki
09.09.2019 07:20
Чему равна сумма чисел 13 в 8 и 13 в 16? результат запишите в двоичной системе счисления....
anna7251
09.09.2019 07:20
Какое число предшествует числу 10↓9 в 9-ричной системе счисления. а)-7. б)-8. в)9...
LizaVeta281
09.09.2019 07:20
Запишите в славянской системе числа 15,25,38,137,596...
7LittleKitten7
09.09.2019 07:20
Написать слово осень n-ое количество раз...
elena1alekseevna
09.09.2019 07:20
ответьте на вопросы что такое окно на рабочем столе компьютера? какие виды окон бывают?...
ВикторияГога
09.09.2019 07:20
При выполнении оператора z: =b∗m значения ячеек оперативной памяти с именами b и m переносятся в процессор, где над ними выполняется операция умножения. полученный результат...
Популярные вопросы
Дайте характеристики главным героям на основе деталей и цитат (стационный...
2
7класс общество. эссе на тему какие социальные нормы я , и почему?...
2
Find the antonymic sentences: 1. the course of english is easy and...
1
Решите 1. определить координаты точки в: хв и ув., если длина линии...
3
На тело действуют две силы под углом 90° друг к другу : f1=2н и f2=6н....
2
Тело, кинутое под углом в 60 градусов к горизонту, через 4 с после...
1
Основою піраміди є ромб, гострий кут якого дорівнює 30°. усі бічні...
1
2. чем стали для главного героя уроки лидии михайловны, только ли...
2
400 г кислорода при неизменном давлении нагрели с 27°c до400 қ. в...
1
1. прочитайте текст. 2. папишите краткое изложение текста от лица...
2
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы: