Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).


Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).

lsrk lsrk    1   16.01.2022 22:36    1

Ответы
Николо223 Николо223  16.01.2022 22:40

ok = True

prev = int(input())

cur = prev

while True:

   cur = int(input())

   if cur == 0:

       break

   if (cur > 0 and prev > 0) or (cur < 0 and prev < 0):

       ok = False

   prev = cur

if ok:

   print("YES")

else:

   print("NO")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика