Нужно написать программу на паскале.

Создать файл действительных случайных чисел. Найти наибольший и наименьший элементы и дописать в файл

Алена0607 Алена0607    1   07.04.2020 12:52    3

Ответы
marijamz2016 marijamz2016  12.10.2020 21:32

===== PascalABC.NET =====

begin

 var f := CreateFile&<real>('MyFile.bin');

 // создаем и заполняем файл

 loop 10 do // файл на 10 чисел

   Write(f, Random(100.0));

 // ищем минимум и максимум

 var (min, max) := (200.0, -100.0);

 f.Seek(0);

 var t: real;

 while not f.Eof do

 begin

   Read(f, t);

   if t > max then

     max := t

   else if t < min then

     min := t;

 end;

 // дозапись в файл

 Write(f, max);

 Write(f, min);

 // если надо - контрольный вывод

 f.Seek(0);

 while not f.Eof do

 begin

   Read(f,t);

   Print(t)

 end;

 // закрыть файл

 f.Close;

end.


Нужно написать программу на паскале.Создать файл действительных случайных чисел. Найти наибольший и
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика