Нужно написать программу на pascal.программа должна посчитать среднюю оценку ученика.например: "введите ваши оценки: 54454",программа должна вывести: "ваш средний : 4,4".человек может вводить сколько угодно значений

Alina25255 Alina25255    2   11.08.2019 13:40    2

Ответы
yulaha3010oxppqh yulaha3010oxppqh  04.10.2020 11:26
Var marks:string; i,m,c,s,k:integer;
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
 if marks[i] in ['2'..'5']
  then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний : ',s/k);
end.

Пример:
Введите ваши оценки: 54454
Ваш средний : 4.4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика