Нужно написать программу на pascal abc net. суть программы такова, чтобы она рандомно выбирала цвета (красный, чёрный или зелёный), но с определёнными шансами, то есть красный=43,75%, чёрный=50% и зелёный=6,25%. в результате программа должна выдать человеку какой цвет выпадет. в множество красного цвета входят числа: 1,5,7,9,11,13,15 в множество чёрных: 2,4,6,8,10,12,14,16 в множество зелёных: 3.

Nuraaaykaaa Nuraaaykaaa    3   19.09.2019 12:30    2

Ответы
замира59 замира59  26.08.2020 23:25
Считая, что функция random() возвращает случайные числа с равномерным законом распределения и что 7/16*100 = 43,75, 8/16*100 = 50, 1/16 = 6,25, задачу можно решить так:
begin
 var c:=random(1,16);
 case c of
  1,5,7,9,11,13,15: writeln(c,' - Красный');
  2,4,6,8,10,12,14,16: writeln(c,' - Чёрный');
  else writeln(c,' - Зелёный');
  end;
end.

Пример:
7 - Красный
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика