Нужно написать программу на Java
Дана матрица размера M × N. Найти максимальный среди минимальных элементов ее строк. Есть код на Паскале

const
rows = 10; { <-- Количество строк }
columns = 10; { <-- Количество столбцов }

var
A: array[1..rows, 1..columns] of integer;
i, j, M, N: byte;
MinElem, MaxMinElem: integer;

begin
repeat
write('M = ');
readln(M)
until (M >= 1) and (M <= rows); { <-- Количество строк от 1 до rows }
repeat
write('N = ');
readln(N)
until (N >= 1) and (N <= columns); { <-- Количество столбцов от 1 до columns }
{ Формируем и выводим матрицу: }
randomize;
writeln('Случайная матрица ', M, 'x', N, ':');
for i := 1 to M do begin
for j := 1 to N do begin
a[i, j] := -100 + random(200); { <-- Случайный элемент -100..99 }
write(a[i, j]:4);
if j = 1 then MinElem := a[i, j] { <-- Инициализация минимального элемента }
else { Сравниваем остальные элементы с минимальным: }
if a[i, j] < MinElem then MinElem := a[i, j]
end;
if i = 1 then MaxMinElem := MinElem { <-- Инициализация максимального минимума }
else
if MinElem > MaxMinElem then MaxMinElem := MinElem;
writeln
end;
writeln;
writeln('Максимальный среди минимальных элементов строк: ', MaxMinElem);
readln
end.

divergent01 divergent01    1   24.02.2020 12:25    8

Другие вопросы по теме Информатика