Нужно написать программу на c++ по данному ( 100 )

задан квадратный массив а из n строк и n столбцов, n – нечетное число. в предложенном массиве можно выделить две диагонали. эти диагонали очерчивают четыре треугольника с числами. произвести замену верхнего и нижнего треугольников, правого и левого треугольников.

lezifequliyeva lezifequliyeva    3   16.12.2019 01:03    4

Ответы
милаш06 милаш06  23.08.2020 11:19

#include <iostream>

using namespace std;

int main()

{

int N, N1;

cout << "kol-vo ctrok ";

cin >> N;

cout << "ko-lvo ctolbcov ";

cin >> N1;

int** mtrx = new int* [N1];

for (int i = 0; i < N; i++)

{

 mtrx[i] = new int[N1];

}

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cin >> mtrx[i][j];

 }

}

cout << endl;

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cout<< mtrx[i][j]<<" ";

 }

 cout << endl;

}

for (int i = 0; i <= trunc(N/2); i++)

{

 for (int j = 0; j <= trunc(N1/2); j++)

 {

  int tmp = mtrx[N - 1 - i][N1-1-j];

  mtrx[N - 1 - i][N1 - 1 - j] = mtrx[i][j];

  mtrx[i][j] = tmp;

 }  

}

cout << endl;

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cout << mtrx[i][j] << " ";

 }

 cout << endl;

}

for (int i = 0; i < N; i++)

{

 delete[] mtrx[i];

}

delete [] mtrx;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика