Нужно написать программу на c (ну или хотя бы на c++)‼️‼️‼️‼️‼️‼️‼️ дана строка символов, состоящая из произвольного текста,слова разделены пробелами.вывести на экран порядковый номер слова, накрывающего к-ю.(если на k-ю позицию попадает пробел, то гомер предыдущего слова)

andkrutoi2018 andkrutoi2018    1   14.09.2019 07:20    3

Ответы
Krasnovadiana11 Krasnovadiana11  07.10.2020 13:51
#include <iostream>using namespace std; int main(){     char str [] = "dd yhd yw dcjkayt dvqv auyj fbajk dyusdv sddw";     int k = 9; //position     int before=  0, after = 0, space = 0;                         for(int i = 0; i <= k; i++){             if(str[i] == ' '){                 space++;             }         }         if(str[k] != ' '){       for(int i = k + 1; str[i]; i++){         if(str[i] == ' ' || str[i] == '\0'){             after = i;                         break;                 }         }         for(int j = k - 1; j >= 0; j--){         if(str[j] == ' ' || j == 0){             before = j;                         break;                 }     }         cout<<space + 1<<" slovo ";         for(int i = before; i < after; i++)         cout<<str[i];         }         else cout<<space<<" slovo"; return 0; }
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика