Нужно написать программу на C++.
На площине дано две точки M (x1, y1) та N (x2, y2) . Узнать, которая из них належить колу, даному уравнению (x−1)2+(y+ 2)2=4 .

GAMERINO GAMERINO    2   28.04.2020 17:25    3

Ответы
Sevinch94 Sevinch94  14.10.2020 01:23

#include <iostream>

int main()

{

   double x1, y1, x2, y2;

   std::cout << "M(x1,y1): ";

   std::cin >> x1 >> y1;

   std::cout << "N(x2,y2): ";

   std::cin >> x2 >> y2;

   if ((x1 - 1) * (x1 - 1) + (y1 + 2) * (y1 + 2) == 4) std::cout << "M(" << x1 << "," << y1 << ")";

   else if ((x2 - 1) * (x2 - 1) + (y2 + 2) * (y2 + 2) == 4) std::cout << "N(" << x2 << "," << y2 << ")";

   else std::cout << "None of the points";

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика