Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных элементов.
15.1. Ввести массив с клавиатуры.
15.2. Найти минимальный положительный элемент.
15.3. Вычислить сумму четных элементов массива.
15.4. Вывести массив на экран в обратном порядке.

fgk200 fgk200    1   19.11.2020 14:52    11

Ответы
chelovekchelovekov99 chelovekchelovekov99  19.12.2020 14:54

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

int main() {

vector<int> arr;

int size, min(9999999), sum(0);

cout << "N: ";

cin >> size;

for (int i = 0; i < size; ++i) {

 int temp;

 cout << "Element #" << i + 1 << ": ";

 cin >> temp;

 arr.push_back(temp);

 if (temp >= 0 && temp < min) {

  min = temp;

 }

 if ((i + 1) % 2 == 0) { // нумеруем элементы с 1

  sum += temp;

 }

}

cout << "Min: " << min << endl;

cout << "Sum: " << sum << endl;

for (int i = arr.size()-1; i>=0; --i) {

 cout << arr[i] << " ";

}

}


Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных элементов. 15
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика