нужно написать программу которая выводит наибольшую цифру в введенном числе.

Кристина01012004 Кристина01012004    1   18.09.2019 13:20    2

Ответы
123настюша321 123настюша321  08.10.2020 00:03
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (n,dmax):=(Abs(ReadInteger('n=')),0);
  while n>0 do begin
    var t:=n mod 10;
    if t>dmax then dmax:=t;
    n:=n div 10
    end;
  Writeln(dmax)
end.

Пример
n= 2450234
5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика