Нужно написать программу которая при вводе координат начальной и конечной ячеек шахматной доски будет решать возможен ли ход в конечную ячейку шахматной фигуры «слон». программа должна вывести: «yes» если ход возможен и «no» если нет. решение в c++

11Ольга1111111 11Ольга1111111    1   01.10.2019 10:01    4

Ответы
keklolcheburek1243 keklolcheburek1243  09.10.2020 07:33

#include <iostream>

using namespace std;

int main(){

long long x1,x2,y,y2;

 cout<<"Enter x1:";

 cin>>x1; // вводим начальную координату по горизонтали

 cout<<"Enter y1:";

 cin>>y; // вводим начальную координату по вертикали

 cout<<"Enter x2:";

 cin>>x2; // вводим конечную координату по горизонтали

 cout<<"Enter y2:";

 cin>>y2; // вводим координату координату по вертикали

if(x1 - y == x2 - y2 || x1 + y == x2 + y2){

 cout << "YES";

}

else{

 cout << "NO";

}

}


else{

 cout << "NO";

}

}

ПОКАЗАТЬ ОТВЕТЫ
079023296 079023296  09.10.2020 07:33

#include "stdafx.h"  

#include <iostream>  


using namespace std;  


int main()  

{  

// input data  

int x1, y1, x2, y2;  


// get data  

co

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика