Нужно написать программу, которая переводит число из 16-ой сс в 10-ю сс, на языке c.

Маша270902 Маша270902    2   11.09.2019 03:30    6

Ответы
137rdh 137rdh  07.10.2020 06:39
#include <stdio.h>

int main(void) {
int n;
printf("Введите число в 16-ричной СС: ");
scanf("%x",&n);
printf("%x(16) = %d(10)",n,n);
return 0;
}

Пример:
Введите число в 16-ричной СС: a1f
a1f(16) = 2591(10)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика