Нужно написать программу которая определяет является ли сумма цифр двухзначного числа четной

Beario Beario    3   18.05.2019 22:40    1

Ответы
Кристина15551 Кристина15551  12.06.2020 03:57

если число не очень длинное, то можно считать в стринг. но если число длинное, то это не прокатит

 

var

q:string;

i,a,n:integer;

 

begin

readln(q):

n:=length(q);

for i:=1 to n do

a:=strtoint(q[i]);

if a mod 2 = 0 then writeln("YES) else writeln("NO");

 

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика