tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
нужно написать программу
нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0,2< =sin ai < =0,5, i=1, n
MariaRils
1 29.05.2019 05:00
10
Ответы
лисичка132
27.06.2020 11:35
#include <iostream>
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dikray1
08.12.2021 17:10
1. Як додати текстові написи до зображення в Inkscape? 3. Як змінити колір символів текстового напису та їх контури в Inkscape? 6. Як змінити розташування літер у...
EvaMilka
08.12.2021 17:09
Сделать аннотацию по этой статье *ссылка на статью под самим вопросом* Аннотация – краткая характеристика содержания статьи. Особенности: 1.4-5 предложений. 2.Передать...
kotofrei231
16.04.2020 15:57
Запиши доменное имя компьютера, зарегистрированного в домене первого уровня образование, в домене второго уровня university и имеющего собственное имя www....
Luxky
24.06.2019 00:20
Изменение размера шрифта относится к: 1)преимуществам 2)недостаткам электронной книги....
Orlolo
11.05.2021 07:27
Какой инструмент позволяет объединить две фигуры и относится к инструментамработы со сплошными?«Обрезка»«Перекрытие»«Вычесть»«Внешняя оболочка»...
SpoonKeeper
11.05.2021 07:23
Перечислите инструменты которые использовал ученик для создания этого объекта....
ЧерепашкаВася
27.04.2020 16:11
Прямоугольный параллелепипед с ребрами 11,22 и 33.Предикат: Vol(a,b,c,v):=Mult(a,b,z),Mult(z,c,v).За...
школьник228253
27.04.2020 16:11
8 класс запустите программу...
MiFanMF
27.04.2020 16:11
ПОЗЯЗЯ;) (напишите полностью тело программы)ЯЗЫК _ Python Напиши тело программы (не название) в которой будет использоваться фон и на этом фоне нарисован дом....
Satana04
27.04.2020 16:11
Добрый день построить блок - схему...
Популярные вопросы
Мама купила 1\4 метров синей ленты и 1\2 метров красной .укажи...
1
Сделать тест! 1)процесс пищеварения молекулы крахмала расщепляются...
1
Скласти розповідне речення з іменником слово...
3
Как изменится период свободных колебаний маятника если его переместить...
3
Укажіть, яке з тверджень є правильним щодо суті романтизму: а)...
3
Усаши есть три заветных желаний, а у федора на одно желание меньше,...
1
Расписать образования слов: голодный, верный, бездомный...
1
нужно составить предложения из слов: 1.drinking,boy,coke,the,is...
2
Укреплённый оборонительный пункт. насильственный захват чужой территории...
1
Звонким колоколом ударом будит зимний воздух. мы работали не даром,...
2
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}