Нужно написать программу: дан массив. нужно отдельно вычислить отдельно сумму чисел, меньших и больших заданного k. !

AksenovaKatya2007 AksenovaKatya2007    2   25.08.2019 22:40    2

Ответы
ovrvoin2 ovrvoin2  05.10.2020 19:45
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Сумма элементов, меньших ',k,': ',
    a.Where(x->x<k).Sum);
  Writeln('Сумма элементов, больших ',k,': ',
    a.Where(x->x>k).Sum)
end.

Пример
k= 45
n= 15
53 45 26 -9 -34 -93 87 52 -72 16 15 -58 73 24 -22
Сумма элементов, меньших 45: -207
Сумма элементов, больших 45: 265
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика