tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужно написать линейную программу
Нужно написать линейную программу перевода четырехзначного двоичного числа в десятичную систему счисления.
gabadunka
1 19.07.2019 10:10
2
Ответы
M0N1C4
07.09.2020 16:23
Var s : String;
Begin
Repeat
Readln(s);
Until Length(s)=4;
Writeln((Ord(s[1])-Ord('0'))*8+(Ord(s[2])-Ord('0'))*4+(Ord(s[3])-Ord('0'))*2+(Ord(s[4])-Ord('0')));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lizochkascherb
12.07.2019 07:50
Решить по паскалю при процедуры и функции 1.дана прямоугольная таблица, которая содержит не более 30 строк и не более 10 столбцов. найти сумму элементов, у которых...
5five3353
12.07.2019 07:50
Шестиклассники аня боря вася галя даша и иван получили в подарок флешки на 1 2 4 8 16 32 гигабайта выясните кто из получил флешку с самого большого и кто самого маленького...
yuliaprok61yulia1206
12.07.2019 07:50
Вчём суть программного принципа работы компьютера?...
vladimlr
12.07.2019 07:50
Вставить пропущенное слово: древний,чем...
temamojet1997
12.07.2019 07:50
Правильно ли написана программа? для заданной функции k=tg(3,4z^3)+cos(z+1,2) вывести на экран значения функции, которые лежат в пределах от -1 до 1 и соответсвующие...
Yanagolko
12.07.2019 08:00
Вмассиве хранится информация о среднедневной температуре ноября (в с°) 1.опишите данный массив . 2.заполните массив случайными целыми числами из отрезка [-3; 7] . 3.выведите...
daniilbesperst
12.07.2019 08:00
Может ли камень быть источником письменной информации...
uikyky
12.07.2019 08:00
Впрограмме алго, напишите программу для нахождения произведения цифр натурального числа n, введенного с клавиатуры....
Nikita6537
12.07.2019 08:00
23 примера суждений в которых речь идет об объектах изучаемых на уроке информатики...
чибик228
12.07.2019 08:00
Как сост программу вычисления объёма куба...
Популярные вопросы
1. Жазусыз адамзат өркениеті дами алмайды Дұрыс/Бұрысдәлел2. Жазудың...
3
Найдите наименьшее значение функции...
3
Укажи предложение с обособленным обстоятельством, выраженным сравнительным...
1
если 2 простое число(A) то 2 наименьшее простое число(B). Если 2...
2
5. Придумайте и запишите к предложению наречие образа действия Оказывается,...
1
Шрифт, на концах букв которого имеются маленькие чёрточки называется...
3
Ребят, у меня проблема. Моя лучшая подруга, с которой мы давно общемся...
2
Запишите 5—6 эпиграфов, преобразуя их в цитаты любым ...
3
У рівнобедреному трикутнику ABC з основою AC кут В=53°. Знайдіть...
2
СОЧ По Истории Казахстана За ранее ❤️❤️❤️...
1
Begin
Repeat
Readln(s);
Until Length(s)=4;
Writeln((Ord(s[1])-Ord('0'))*8+(Ord(s[2])-Ord('0'))*4+(Ord(s[3])-Ord('0'))*2+(Ord(s[4])-Ord('0')));
end.