НУЖНО НАПИСАТЬ КОД НА ПИТОНЕ ИЛИ НА С Извините, что последние)

Сокращение дроби
Дана дробь ab. Требуется её сократить, то есть записать это же число в виде cd, где c — целое число, d — натуральное число и d минимальное возможное.

Входные данные

Вводятся два целых числа a и b (–100≤a≤100, 0
Выходные данные

Выведите два числа c и d.

Примеры
Ввод 1
18 27
Вывод
2 3

мотя104 мотя104    1   03.06.2020 14:34    64

Ответы
Новичок345 Новичок345  15.10.2020 12:56

Python

a, b=map(int,input().split())

c=a

d=b

for i in range(-101,101):

   if i!=0 and a%i==0 and b%i==0 :

       c=a//i

       d=b//i

print(c,d ,end=" ")

а эффективней использовать алгоритм Евклида.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика