Нужно на С++ с контейнера vector Цифры
На вход программе подается последовательность из N чисел от 1 до 9. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат.

Входные данные

В первой строке записано натуральное число N (N≤100) — количество элементов в последовательности. В следущей строке записано N целых чисел от 1 до 9 — элементы последовательности.

Выходные данные

Выведите ответ на задачу.

Диана05005 Диана05005    1   15.03.2021 22:42    32

Ответы
yevdokimenkoal yevdokimenkoal  15.03.2021 22:50

#include <iostream>

#include <vector>

using namespace std;

int main(){

   vector<int> m(10,0);

   int n,x;

   cin >> n;

   while(n--){

       cin >> x;

       m[x]++;

   }

   for(int i = 1; i <= 9; i++)

       cout << m[i] << " ";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика