Нужно до 22.00 05.11.! написать программу, которая заменяет цифру числа названием этой цифры. например, заменить число 4563 на строку четыре пять шесть три.

Хулиганочка13 Хулиганочка13    3   08.07.2019 00:10    5

Ответы
69Maxsim96 69Maxsim96  31.07.2020 01:48
Var
  n: integer;
  answer: string;
 
begin
  read(n);
  while n > 0 do {Пока есть цифры добавляем последнюю цифру числа к ответу и отбрасываем ее}
  begin
    case n mod 10 of
      0: answer := 'ноль ' + answer;
      1: answer := 'один ' + answer;
      2: answer := 'два ' + answer;
      3: answer := 'три ' + answer;
      4: answer := 'четыре ' + answer;
      5: answer := 'пять ' + answer;
      6: answer := 'шесть ' + answer;
      7: answer := 'семь ' + answer;
      8: answer := 'восемь ' + answer;
      9: answer := 'девять ' + answer;
    end;
    n := n div 10;
  end;
  writeln(answer);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика