Нужно было написать программу, которая находит наибольшее из трех чисел a, b и c. Начинающий программист написал фрагмент программы так: if a > b then
M := a
else
M := b;
if c > b then
M := c
else
M := b;
При каких наборах значений a, b, c эта программа работает неверно?
Выберите все подходящие варианты.

a = 1; b = 4; c = 7
a = 1; b = 7; c = 4
a = 7; b = 4; c = 1
a = 4; b = 7; c = 1
a = 7; b = 1; c = 4
a = 4; b = 1; c = 7

ОТВЕТ ДАЙТЕ ПРАВИЛЬНЫЙ НЕ ОТ БАЛДЫ

kuzmov55 kuzmov55    2   12.02.2021 19:53    6

Ответы
taibat3 taibat3  14.03.2021 19:53

a = 1; b = 4; c = 7

a = 1; b = 7; c = 4

a = 4; b = 7; c = 1

a = 4; b = 1; c = 7

Объяснение:

Вот код программы на C++:

#include <iostream>

using namespace std;

void main()

{

setlocale (LC_ALL, "RUS");

int a, b, c, M;

cout << "Введите число а: ";

cin >> a;

cout << "Введите число b: ";

cin >> b;

cout << "Введите число c: ";

cin >> c;

if (a > b)

{

 M = a;

}

else

{

 M = b;

}

if (c > b)

{

 M = c;

}

else

{

 M = b;

}

cout << "Наибольшее число: " << M << endl;

}

Можешь сам(а) на онлайн-компиляторе проверить выражения, если не уверен(а).

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика