Нужна Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 109, и выводится минимальная цифра этого числа. Программист торопился и написал программу неправильно.

var N: longint;
digit, min_digit: integer;
begin
readln(N);
min_digit := 9;
while N >= 10 do
begin
digit := N mod 10;
if digit < min_digit then
min_digit := digit;
N := N div 10;
end;
writeln(digit);
end.
Последовательно выполните следующее.
1.Напишите, что выведет эта программа при вводе числа 547.
2.Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки:
1) выпишите строку, в которой сделана ошибка;
2) укажите, как исправить ошибку, – приведите правильный вариант строки.
Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.

АйлинМалик АйлинМалик    2   30.04.2020 11:46    5

Другие вопросы по теме Информатика