НУЖНА Т-Т
Нужно составить программу в паскале.
Дан массив из 20 элементов,заполненный случайными числами от -15 до 30. Нужно найти номера максимального и минимального элементов этого массива.

kvkv2 kvkv2    1   26.04.2020 01:58    5

Ответы
propprap propprap  28.08.2020 13:20

1.

program z1;

const n=20;

var a:array [1..n] of integer;

i,maxi,mini:integer;

begin

maxi:=1;

mini:=1;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > a[maxi] then maxi:=i;

if a[i] < a[mini] then mini:=i;

write(a[i],' ')

end;

writeln;

writeln('Максимальный элемент a[',maxi,'] = ',a[maxi]);

writeln('Минимальный элемент a[',mini,'] = ',a[mini])

end.

2.

program z1;

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

max:=-15;

min:=30;

write('Массив А: ');

for i:=1 to n do

begin

a[i]:=random(46)-15;

if a[i] > max then max:=a[i];

if a[i] < min then min:=a[i];

write(a[i],' ')

end;

writeln;

for i:=1 to n do

begin

if a[i]=max then writeln('Максимальный элемент a[',i,'] = ',a[i]);

if a[i]=min then writeln('Минимальный элемент a[',i,'] = ',a[i])

end

end.

Объяснение:

1. Не учитывает повтор элементов. Ищет первый максимальный и первый минимальный элементы.

2. Учитывает повтор элементов, но надо точно задавать max и min исходя из диапазона чисел.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика