НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то есть недоработка и они работают неправильно. Компилятор никакой ошибки не выводит, поэтому не могу разобраться в чём дело...
Прикрепляю задания, свои коды и скрины работы прог:

1)Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Текст нужно придумать самостоятельно.

Мой код:

program udalenye;
var s, s1: string;
i: byte;
begin
writeln('введите текст, состоящий из 6 слов');
readln(s);
writeln('исходная строка: ', s);
s1:='';
for i:=1 to length(s) do
if (s[i]<>'о') then s1:=s1+s[i];
writeln('строка после удаления всех букв "о": ', s1);
end.

2)Определить, сколько раз в тексте встречается буква «и».

В качестве входных данных введите текст, состоящий из Ваших фамилии, имени и отчества.

Мой код:

program bukva;
var s: string;
i, k: integer;
len: byte;
begin
k:=0;
writeln('введите имя, фамилию и отчество');
readln(s);
len:=length(s);
for i:=1 to len do
begin
if s[i]='и' then k:=k+1;
end;
writeln('буква "и" встречается в тексте ', k, ' раза(раз)');
end.


НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то
НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то

поля875 поля875    1   04.05.2021 11:00    4

Другие вопросы по теме Информатика