tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужна ! ( программа с++) с датчика
Нужна ! ( программа с++) с датчика случайных чисел заполнить двоичную матрицу 5х10. определить номер столбца с наибольшей суммой значений элементов. заранее за ( если можно скиньте скрин из этой программы с этим )
рустамммм
2 31.07.2019 14:00
6
Ответы
alkatrasnoob
28.09.2020 17:09
//Dev-C++ 4.9.9.2
#include <iostream>
#include <ctime>
using namespace std;
int main(){
srand(time(NULL));
int ma[5][10];
int maxn=0;
double s=0;
double max=-2147483647;
for(int i=0;i<10;i++)
for(int j=0;j<5;j++)
ma[i][j]=rand()%2;
for(int j=0;j<5;j++){
for(int i=0;i<10;i++)
s=s+ma[i][j];
if(s>max){max=s; maxn=j;}
s=0;}
cout<<"Matrix"<<endl;
for(int i=0;i<10;i++){
for(int j=0;j<5;j++)
cout<<ma[i][j]<<" ";
cout<<endl;}
cout<<maxn+1;
cin.get();
cin.get();
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
VasyaKotikSnake
05.07.2019 00:20
Найдите основание х системы счисления если 2002x=130(в 10)...
milenaborowik
09.09.2021 09:06
наведіть приклади використання електронних документів у професійній діяльності і побуті...
Mak78434
09.09.2021 09:05
Доступ к файлу lоt.htm, находящемуся осуществляется по протоколу http. В таблице фрагменты адреса файла закодированы буквами от А до Ж. Запишите последовательность этих букв, кодирующую...
Lisa030105
09.09.2021 09:00
Даны действительные числа x, y. Если x и y положительные числа, вычтите их из корня; если только один из них положительный, возведите их в квадрат. Если x и y отрицательные числа,...
denis1120
16.09.2019 20:30
«составить сл. лог. высказывания, истинные в случаях. произведение чисел х и z является двузн. числом и крат. 3 или 2»...
NameXD
16.09.2019 20:30
Закрасить вертикальный коридор неизвестной длины робот где-то в коридоре...
SillyLittleFool
16.09.2019 20:30
Определите глубину цвета графического изображения, если при размере 600 пикселей на 500 пикселей его объем равен 600000бит. заранее большое...
gusarova17
16.09.2019 20:40
в трапеции заданы стороны a,b,c,d. найти и вывести на экран остальные элементы трапеции (углы, площадь) . язык с или с++...
balbasenok
18.08.2019 12:40
Составить программу для решения следующей : дана матрица размером m*n и число k (1 =k =m). найти сумму и произведение элементов k -ой строки данной матрицы...
alechka2502
18.08.2019 12:30
Реши . веселые человечки решили сходить в поход. пончик испёк для всех пирожки с мясом, яблоками, капустой и повидлом и разложил их по пакетам, кулькам и коробкам. пирожков с мясом...
Популярные вопросы
ЗАДАНИЕ ПО АНГЛИЙСКОМУ. 1. Раскройте скобки, поставив глагол в the Future Continuous...
3
найдите производную функции используя правило нахождения производной произведения...
2
решите эти 4 примера. распишите подробно. даю. Нужно решить с ОДЗ и т.п...
2
с английским языком, 1.в каком из следующих слов звук передаваемый буквой у отличается...
2
Ребят решить немколько задач по физике Задача 1. На последовательное соединение...
2
решить задания. Буду очень благодарен. с меня...
1
Создать класс с описанием и минимум 4 функциями для каждого объекта. Нейтрон,...
3
Під час обчислення журналу теодолітного знімання отримані дані: сума виміряних...
3
Найти все целые решения неравенства: 1 5х-3≤12...
2
Вычислить Э.Д.С гальванического элемента при 250С Степень диссоциации солей принять...
3
#include <iostream>
#include <ctime>
using namespace std;
int main(){
srand(time(NULL));
int ma[5][10];
int maxn=0;
double s=0;
double max=-2147483647;
for(int i=0;i<10;i++)
for(int j=0;j<5;j++)
ma[i][j]=rand()%2;
for(int j=0;j<5;j++){
for(int i=0;i<10;i++)
s=s+ma[i][j];
if(s>max){max=s; maxn=j;}
s=0;}
cout<<"Matrix"<<endl;
for(int i=0;i<10;i++){
for(int j=0;j<5;j++)
cout<<ma[i][j]<<" ";
cout<<endl;}
cout<<maxn+1;
cin.get();
cin.get();
return 0;
}