tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нужна программа на pascal abc,
Нужна программа на pascal abc, которая будет находить среднее арифметическое n чисел и округлять его до целых. 100 ! !
Кэйт777
3 19.09.2019 05:10
5
Ответы
VladimirOwl
08.10.2020 01:31
Var
i,n,m,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do begin Read(m); s:=s+m end;
Writeln('Cреднее арифметическое округленно равно ',Round(s/n))
end.
Пример
n=5
3 6 2 4 3
Cреднее арифметическое округленно равно 4
ПОКАЗАТЬ ОТВЕТЫ
knestor
08.10.2020 01:31
Program n1;
var n,i,a,sum: integer;
begin
write('n=');
readln(n);
sum:=0;
writeln('введите ',n,' чисел: ');
for i:=1 to n do
begin
readln(a);
sum:=sum+a;
end;
write('срзнач: ',round(sum/n));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ιιIαγρμα
22.03.2019 15:33
Даны четыре вещественных чисел x,y,x,y, представляющих собой координаты точек а и в.написать программу в scilab,определяющую,какая из этих точек ближе к началу координат и выводящую...
Still227
22.03.2019 15:17
9) найти функцию y = 1/x ,если x = 0,1 (0,1) 2. 6) найти функцию y=ln x, если x = 2 (0,2) 3. составить программу на паскале, с циклами goto, всей вот этой дьчию...
kalabukhovalina
09.12.2021 17:08
Задачи по информатике, 1) Объем видеопамяти равен 1200 Кб и она разделена на 4 страницы. Какое максимальное количество цветов можно использовать при разрешающей экрана 800*600...
rusyabarnakov
09.12.2021 17:08
кто решит ? Укажите типы данных в таблице (в столбце один ответ) * Подпись отсутствует Текстовый Числовой Денежный Процентный Столбец Должность Столбец Оклад Столбец Месячный...
диана2340
04.08.2019 06:50
Какие языки в настоящее время являются самыми распространеными в мире?...
Roma1971
04.08.2019 07:00
Кто такой клод шеннон и чем он занимается?...
Пушинканя231
04.08.2019 07:00
1.в трехзначном числе х зачеркнули его вторую цифру.когда к образованному при этом двузначному числу слева приписали вторую цифру числа х,то получилось число 546,найти х. 2.даны...
NekitKrut2007
04.08.2019 07:00
Опишите систему хранения файлов на диске...
savaam1
04.08.2019 07:10
Составьте программу решения : вычислить значение y при значении x=: x²-4x³, при x 0. |x| , при x≤0. , !...
Dzhemre69
04.08.2019 07:10
Постройте граф состоящий из пунктов a,b,d,e,f. при этом пункты cd,fc,ed,be,af не соединяются. найти все точки пересечения и назвать их.(ответ зарисовать и выделить точку)...
Популярные вопросы
Решить сколько раз увеличится скорость реакции при росте температуры от 20...
1
Как выбрать испытания на гто которые хочешь проходить?...
3
Мини сочинение на тему религия древний индии...
2
Переведите на казахский грипп – это вирусная инфекция, поражающая нос, горло...
3
Подберите к словам персики, груши, смородина, тыква, виноград, яблоко, лимон...
3
Якими усними джереламипослуговуються вчены для выд твореня минулиг за княжих...
3
Установите соответствие полезное ископаемое. продукция 1 нефть. а. сталь...
1
Миша купил 20 марок. на одной странице альбома он разместил 4 марки,а на...
2
План изучения природного сообщества...
2
Написать сочинение на тему тарас бульба завтра сдавать. тарас бульба личность...
2
i,n,m,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do begin Read(m); s:=s+m end;
Writeln('Cреднее арифметическое округленно равно ',Round(s/n))
end.
Пример
n=5
3 6 2 4 3
Cреднее арифметическое округленно равно 4
var n,i,a,sum: integer;
begin
write('n=');
readln(n);
sum:=0;
writeln('введите ',n,' чисел: ');
for i:=1 to n do
begin
readln(a);
sum:=sum+a;
end;
write('срзнач: ',round(sum/n));
end.