Нужна по информатике. : написать программу вычислить произведение из двух наибольших введенных с клавиатуры чисел.( в паскале). проще говоря, у меня есть три числа, я должен ввести их, и два наибольших из них должны перемножаться. нужно написать программу используя условные операторы. заранее .

roman5555554 roman5555554    3   24.06.2019 15:10    2

Ответы
leksios leksios  20.07.2020 01:59
Var
  a,b,c:integer;
begin
  Write('Введите три целых числа: '); Readln(a,b,c);
  if a>b then
    if b>c then Writeln(a*b) else Writeln(a*c)
  else
    if a>c then Writeln(a*b) else Writeln(b*c)
end.

Тестовое решение:
Введите три целых числа: 5 -2 7
35
ПОКАЗАТЬ ОТВЕТЫ
yudaeva78 yudaeva78  20.07.2020 01:59
Var m: array [1..3] of real;
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do  
begin 
if m[i]<m[imin] then imin:=i; 
if m[i]>m[imax] then imax:=i; 
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика