Нужна : ) напишите программу вывода на экран элементов одномерного целочисленного массива из 25-ти элементов и нахождения числа элементов этого массива, которые при делении на 5 остаток 2. элементы массива генератором случайных чисел.

Школа5101 Школа5101    2   29.08.2019 23:30    5

Ответы
мединалуна мединалуна  06.10.2020 03:57
Var max,min,i,s:integer;
mas:array[1..25] of integer;
begin
randomize;
write('Введите диапазон: '); readln(max,min);
if(min>max) then begin
max:=max+min;
min:=max-min;
max:=max-min;
end;
for i:=1 to 25 do
mas[i] := min + random(max-min+1);
for i:=1 to 25 do begin
write(i,'-ый элемент: ',mas[i]);
if((mas[i] mod 5) = 2) then begin s:=s+1; writeln('+'); end
else writeln();
end;
write('Сумма элементов, которые при делении на 5 дают остаток 2: ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика