Нужна ! написать программу в паскале. ввести n чисел из диапазона от 0 до 10 000 и вывести количество трехзначных чисел ,а если таких чисел нет,то вывести нет

ina20021 ina20021    2   18.09.2019 16:00    6

Ответы
АлексейЦифры АлексейЦифры  08.10.2020 00:21
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadSeqInteger(ReadInteger('n='))
      .Where(t->t.InRange(100,999)).Count;
  if k>0 then k.Println
  else Writeln('НЕТ')
end.
ПОКАЗАТЬ ОТВЕТЫ
Uses crt;
type TDMassiv = record
intMassiv : array of integer // Создали тип "динамический массив"
end;
var N, i, k : integer;
A : TDMassiv // Создали переменную A нового типа TDMassiv
Begin
clrscr;
randomize;
write('Vvedite kol-vo chisel');
readln(N);
SetLength(A, N) // Определяем, что массив А будет размера N элементов.
for i=1 to N do
begin
A[i] := random(10001); // Заполняем массив случайными числами [0..10000]
end;
k := 0; // k - это счетчик трехзначных чисел
for i=1 to N do
begin
if (A[i] >= 100) AND (A[i] <= 999) then k := k+1; // Считаем трехзначные числа
end;
if k := 0 then writeln ('HET') else writeln('Trehznachnyh chisel = ', k);
// Выводим посчитанное количество чисел на экран
END.
ПОКАЗАТЬ ОТВЕТЫ