Нужна до напишите эффективную программу, которая по двум данным натуральным числам p и q не превосходящим 30 000, подсчитывает кол-во натуральных чисел с последней цифрой 0 на интервале (p,q) (не включая концы интервала) программа получает на вход 2 натуральных числа p и q, при этом гарантируется, что 1≤p

getmanchenko02 getmanchenko02    1   07.06.2019 17:00    9

Ответы
YankaManky YankaManky  01.10.2020 21:40
Код программы для С#. Думаю при желании можно запросто переписать на любой другой язык программирования.

Console.WriteLine("Введите p");

 double p = Convert.ToInt16(Console.ReadLine());

Console.WriteLine("Введите q");

double q = Convert.ToInt16(Console.ReadLine());

int c = 0;   

double x = 0; 

 for (double i = p + 1; i < q - 1; i++) { x = i % 10; if (x == 0) c++; }           

Console.WriteLine("");   

Console.WriteLine("Количество натуральных чисел с последней цифрой 0 на отрезке (p,q) = "+ c);              

 Console.ReadLine();

При желании могу скинуть уже готовую программу.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика