Ниже приведена программа, записанная на пяти языках программирования. Алгоритмический язык
Паскаль
алп
var s,t: integer;
нач
begin
цел s, t
readln(s);
Ввод 8
readln(t);
Ввод с
readln (А);
Ввод А
if (s > А) or (t > 12)
если 8 > A или t > 12
then
то вывод "YES
writeln("YES")
иначе вывод "NO
else
все
writeln("NO")
КОН
end.
Бейсик
DIM S, t AS INTEGER
INPUT S
INPUT t
INPUT A
IF S > A OR t > 12 THEN
PRINT "YES"
ELSE
PRINT "NO"
ENDIF
Python
S = int (input())
t = int (input())
A = int (input())
if (s > А) or (t > 12):
print ("YES")
else:
print ( "NO")
CH
#include <iostream>
using namespace std;
int main() {
int s, ti
cin >> S;
cin >> t;
cin >> А;
if (s > А) or (t > 12)
cout << "YES" << endl;
else
cout << "NO" << endl;
return 0;
Было проведено 9 запусков программы, при которых в качестве значений
переменных и t вводились следующие пары чисел:
(13, 2); (11, 12); (-12, 12); (2,-2); (-10, -10); (6, -5); (2, 8); (9, 10); (1, 13).
Укажите наибольшее целое значение параметра А, при котором для
указанных входных данных программа напечатает «NO» шесть раз.

Катерина122333 Катерина122333    1   19.10.2020 02:51    34

Другие вопросы по теме Информатика