Ни откуда не копировать!
Составьте программу решения квадратного уравнения с использованием подпрограммы-функции.

arustamianan arustamianan    1   22.04.2020 10:09    3

Ответы
пецааааа1 пецааааа1  13.10.2020 15:56

var a,b,c, x1,x2,D: real;

begin

writeln(' а,б,с : ');

readln(a,b,c);

D := b*b - 4*a*c;

if D<0 then writeln('нет ответа') ;

if D=0 then

begin

x1 := -b/2/a;

writeln('х1 : ',x1:0:3);

end;

if D>0 then

begin

x1 := (-b-sqrt(D))/2/a;

x2 := (-b+sqrt(D))/2/a;

writeln('х1 и х2: x1=',x1:0:3,' x2=',x2:0:3);

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика