Несложная программа на python! Написать программу которая в каждую новую строку выводит новое число за логикой: 0+1-2+3-4+5-6+7-8+9-10 (результат каждой новой операции должен выводится в новую строку). Думаю всё понятно, если есть вопросы - спрашивайте.

nata524 nata524    2   22.12.2020 01:17    3

Ответы
666Dim 666Dim  21.01.2021 01:17

s = 0

for i in range(1,12):

   print(0,end=" ")

   for j in range(1,i):

       if j % 2 == 0:

           print('-',j,end=" ")

           s -= j

       else:

           print('+',j,end=" ")

           s += j

   print('=', s)

   s = 0

   print()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика