Необходимо составить программу с двумерным массивом. для заполнения данного массива нужно использовать генератор случайных чисел. i - отвечает за номер строки. j - отвечает за номер столбца. заполненные массивы должны выглядеть так: при const n=3 1 2 1 2 3 2 1 2 1 при const n=5 1 2 3 2 1 2 1 2 1 2 3 2 1 2 3 2 1 2 1 2 1 2 3 2 1 желательно, составить блок-схему.

llizka094 llizka094    1   26.05.2019 07:30    7

Ответы
lincha3 lincha3  22.06.2020 17:12
В программе две константы: n и m. n отвечает за размер массива, m за максимальное значение случайного числа от  0 до на 1 меньше чем само m.

Program Zadacha;
Const n = 5; m = 5;
Var a: Array [1..n, 1..n] of Integer;
i, j: Integer;
Begin
Randomize;
For i := 1 To n Do
For j := 1 To n Do
a[i, j] := Random(m);
WriteLn('Результат:');
For i := 1 To n Do
Begin
For j := 1 To n Do
Write(a[i, j], ' ');
WriteLn;
End;
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика