Необходимо решить следующую предметную и написать программу на языке паскаль. для любого целого k обозначим количество цифр в его десятичной записи ц(k). например: ц(1)=1, ц(9)=1, ц(10)=2. дано натуральное число n. вычислить: ( ц(1)/1 ) + ( ц(2)/2^2 ) + +( ц(n)/n^2 )

mariyalesnyak mariyalesnyak    3   03.10.2019 05:50    3

Ответы
anastasiyaaldo anastasiyaaldo  09.10.2020 13:21

program crash;

 

var n, k: integer;

   r: real;

 

begin

 write('n = ');

 readln(n);

 k := 0;

 r := 0;

 while n > 0 do

   begin

     k := k + 1;

     r := r + (n mod 10) / (k * k);

     n := n div 10

   end;

 writeln('r = ', r:0:14);

 readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика